SOLID-IDE メニュー構成


ファイルメニュー

  • 新規作成(N)
    • プロジェクト(P)

      テンプレートから新規ソリューションや新規プロジェクトを生成する。 現状でサポートされているものは以下の通りです。

      ソリューション
      • SOLIDローダブルアプリケーション

      • SOLIDローダブルアプリケーション (単独ビルド)

      • SOLID DLL

      • SOLID DLL (単独ビルド)

      プロジェクト
      • SOLIDアプリケーション

      • SOLIDスタティックライブラリ

    • ファイル(O)

      C/C++ のソースやヘッダファイル等の新規作成。

  • 開く(O)
    • プロジェクト/ソリューション(P)

      プロジェクトやソリューションのオープン

    • ファイル(F)

      ファイルのオープン


  • 追加(D)

    ソリューションへのプロジェクトの追加

    • 新しいプロジェクト(N)

      新規プロジェクトを追加する。 新規作成(N) ‣ プロジェクト(P) と同じ動作

    • 既存のプロジェクト(E)

      ソリューションに既存のプロジェクトを追加する。すでにある .ptproj を選択して追加


  • 閉じる(C)

    ソースビューで表示されているファイルをクローズ

  • ソリューションを閉じる(T)

    今開いているソリューションをクローズ


  • <ファイル名> の保存(S)

    ソースビューで表示されているファイルをセーブ

  • 名前を付けて <ファイル名>を保存(A)

    ソースビューで表示されているファイルに別名を付けてセーブ

  • すべてを保存(L)

    すべてのファイルをセーブする。

  • テンプレートのエクスポート(E)

    プロジェクト、ファイルを新規作成する際に使用するテンプレートをエキスポートする


  • ページ設定(U)

    印刷用のページ設定

  • 印刷(P)

    ソースビューで表示されているファイルを印刷


  • 最近使ったファイル(F)

    最近使ったファイルのリストから選択してオープン

  • 最近使ったプロジェクトとソリューション(J)

    最近使ったプロジェクトとソリューションのリストから選択してオープン


  • 終了(X)

    SOLID-IDE を終了


編集メニュー

  • 元に戻す(U)

    編集操作のキャンセル

  • やり直し(R)

    キャンセルした編集操作の再実行


  • 切り取り

    選択部分の切り取り(クリップボードにコピー)

  • コピー

    選択区分をクリップボードにコピー

  • 貼り付け

    クリップボードの内容を貼り付け

  • 削除

    選択部分を削除


  • すべて選択

    選択中のドキュメントを全選択


  • 検索と置換
    • クイック検索

      現在ウインドウからの検索

    • クイック置換

      現在ウインドウでの置換

    • フォルダを指定して検索

      検索対象を指定して文字列を検索

      検索対象
      • すべての開かれているドキュメント

      • ソリューション全体

      • 現在のプロジェクト

      • ソリューション全体(外部アイテムを含む) (※未対応)

      • 現在のプロジェクト(退部アイテムを含む) (※未対応)

    • フォルダを指定して置換

      検索対象を指定して文字列を置換

      検索対象
      • すべての開かれているドキュメント

      • ソリューション全体

      • 現在のプロジェクト

      • ソリューション全体(外部アイテムを含む) (※未対応)

      • 現在のプロジェクト(退部アイテムを含む) (※未対応)

  • ジャンプ

    指定行へのジャンプ

  • 移動 (※未対応)

    特定の項目に移動


  • テキストとしてファイルを挿入

    ファイルからテキストを入力する

  • 詳細
    • フォーマット

    • タブの設定

    • 大文字<->小文字変換

    • 行移動

    • スペース削除

    • コメント化・コメント化解除

    • インデント

  • ブックマーク

    特定のファイル位置に設定するブックマーク

    • 特定のファイル位置にブックマークを設定

    • ブックマークの有効無効

    • ブックマークへの移動

  • アウトライン

    アクティブではないプリプロセッサブロックの展開/折り畳み

  • IntellSense
    • メンバの一覧

      構造体やクラスのメンバーの一覧を表示

    • パラメーターヒント

      関数のパラメータのリストを表示

    • クイックヒント

      コード内の識別子の宣言全体が表示

    • 入力候補

      カーソル個所の入力候補(変数名や関数名の補完等)を表示

    • スニペットの挿入

      定型文を挿入する

    • ブロックの挿入

      定型文を挿入する

  • リファクター (※未対応)


表示メニュー

  • 開く

    ファイルを開く

  • ファイルを開くアプリケーションの選択

    拡張子ごとにファイルを開くアプリケーションを設定


  • ソリューションエクスプローラー

    ソリューションを構成するプロジェクトと、各プロジェクトに 登録されたファイルのリスト表示をするソリューションエクスプローラを表示

    デフォルトでは表示されているので表示されなくなった場合には、このメニュを使用します


  • ブックマークウインドウ

    ソースファイルの指定した行にブックマークを設定したり、 設定したブックマークにジャンプしたりします

  • 呼び出し階層 (※未対応)

  • クラスビュー (※未対応)

  • コード定義ウインドウ

    選択されている部分の定義を表示する

  • オブジェクトブラウザー (※未対応)

  • エラー一覧

    ビルド時のエラー、警告を表示するウインドウを表示。デフォルトで有効

  • 出力

    以下の情報を表示するウインドウを表示。デフォルトで有効

    • ビルド時のツールチェインからの出力

    • デバッグ時のデバッガから出力

  • リソースビュー (※未対応)

  • スタートページ

    SOLID-IDE のスタートページ(ソリューションを指定せずSOLID-IDEを起動した際の画面)を表示

  • ツールボックス (※未対応)

  • 通知

    SOLID-IDE への通知(バージョンアップ等)ウインドウを表示

  • 検索結果
    • 検索結果1

      [フォルダを指定して検索]で、[結果オプション]から出力先として指定できます

    • 検索結果2

      [フォルダを指定して検索]で、[結果オプション]から出力先として指定できます

    • シンボルの検索結果

      [定義への移動]時に候補が複数ある場合に表示される

  • その他のウインドウ
    • コマンドウインドウ

      Visual Studio のコマンドウインドウを開きます。Visual Studio のコマンドを実行可能です

    • Webブラウザー

      Web ブラウザーのウインドウを実行 デフォルトは SOLID のHPです

    • マクロ展開エクスプローラー

      マクロ展開エクスプローラー ウインドウを表示

      ソースウインドウでマクロにカーソルを合わせ、右クリックのポップアップメニューで "マクロ展開"を選んでも表示されます。

    • サイズプロファイラー

      サイズプロファイラー ウインドウを表示

    • ターミナルウインドウ

      以下の ターミナルのウインドウ を表示 それぞれのターミナルをリストボックスから選んだ後、リストボックス右の「新しいターミナル」のツールボタンをクリックしてください

      • PowerShell

      • Cmd

      • WSL Bash

      • <Seral Port>

      • <SSH>

      注釈

      WSL Bash は WSL が有効になっている必要があります。

      注釈

      <Serial Port> や <SSH> の通信設定は、「新しいターミナル」をクリックした際に表示されるダイアログで入力します

    • ドキュメントアウトライン (※未対応)

    • プロパティウインドウ (※未対応)

    • タスク一覧 (※未対応)


  • ツールバー

    ツールバーに表示するツールボタンの設定。 太字 強調しているものがデフォルトで選択されています。

    • HTMLソースの編集

    • Report

    • Report Borders

    • Report Formatting

    • Ribbon エディター

    • RTOS

    • Webブラウザー

    • XMLエディター

    • イメージエディター

    • クエリデザイナー

    • ソース管理

    • ダイアログエディター

    • テキストエディター

    • テーブルデザイナー

    • デバッグ

    • デバッグの場所

    • ビューデザイナー

    • ビルド

    • ファイルの比較

    • レイアウト

    • 書式設定

    • 標準

    • カスタマイズ

  • 全画面表示

    フォーカスの当たっているウインドウを全画面表示

  • すべてのウインドウ

    フローティング表示のウインドウを表示


  • 前に戻る

  • 次に進む

  • 次のタスク (※未対応)

  • 前のタスク (※未対応)


  • プロパティマネージャ

    .props ファイルを編集する。ただし、手動や他の機能で編集している場合は想定しない動作をする可能性があります

  • プロパティページ

    ソリューションエクスプローラー内で選択されているプロパティページを表示


プロジェクトメニュー

  • スタートアッププロジェクトに設定

    ソリューションエクスプローラで選択されているプロジェクトを「スタートアッププロジェクト」に設定します。 ソリューションエクスプローラのポップアップメニューからも可能

  • プロジェクト依存関係

    プロジェクトのビルド依存関係を設定します。 ソリューションエクスプローラのポップアップメニューからも可能

  • プロジェクトのビルド順序

    プロジェクトのビルド順序を設定します。 ソリューションエクスプローラのポップアップメニューからも可能


  • <プロジェクト名>のプロパティ

    ソリューションエクスプローラで選択されているプロジェクトのプロパティを設定します。 ソリューションエクスプローラのポップアップメニューからも可能


ビルドメニュー

  • ソリューションのビルド

    ソリューションのビルドを行います。 更新が不要なプロジェクトのビルドは行いません(ビルド依存関係に従います)

  • ソリューションのリビルド

    ソリューションのリビルドを行います。 各プロジェクトをクリーンしてビルドを繰り返します(ビルド依存関係従います)

  • ソリューションのクリーン

    ソリューション中の全プロジェクトをクリーンします。

  • 関数情報の表示

    関数の静的な呼び出し関係情報 を表示

    関数の静的な呼び出し関係情報用にコンパイルをやり直しますので、フルビルドと同じだけの時間がかかります。 また、この機能呼出し後にデバッグを行うにはデバッグ用のフルビルドが必要になります


  • <プロジェクト名>のビルド

    ソリューションエクスプローラで選択されているプロジェクトをビルドします。 再コンパイル不要なファイルのコンパイルは行いません

  • <プロジェクト名>のリビルド

    ソリューションエクスプローラで選択されているプロジェクトをクリーンしてからビルド

  • <プロジェクト名>のクリーン

    ソリューションエクスプローラで選択されているプロジェクトをクリーン

  • プロジェクトのみ
    • プロジェクトのみでコード分析を実行

      ソリューションエクスプローラで選択されているプロジェクトに対して 静的解析 を実行


  • バッチビルド

    複数のプロジェクトと構成を指定してビルドを実行


  • コンパイル

    ソリューションエクスプローラで選択されているソースファイルをコンパイル


デバッグメニュー

  • ウインドウ
    • ブレークポイント

      ソフトウェアブレークポイントの管理

    • デバッグ例外

      デバッグ例外のウインドウを開きます。デバッグ例外発生時には自動的に開きます

    • ハードウェアブレークポイント

      ハードウェアブレークポイントの管理

    • 出力

      出力ウインドウにデバッグの出力を表示

    • タスク (※未対応)

    • 並列スタック

      並列スタックウインドウ では関数の呼び出し履歴状態を有効な全タスクおよび割り込みコンテキストに関してグラフィカルに表示

    • 並列ウォッチ

      異なるコンテキストのウォッチ式を評価して値を表示

    • ウォッチ

      ウォッチ式を評価して値を表示

    • 自動変数

      PCの現在位置に関連がありそうな自動変数を表示するウインドウを表示

    • ローカル

      PCの現在位置で有効なローカル変数を表示するウインドウを表示

    • イミディエイト

      PARTNERデバッガで対応している式や変数を直接入力して表示

    • PARTNERコマンドウインドウ

      PARTNERデバッガのコマンドをコマンドラインで入力して実行するウインドウ を表示

      注釈

      すべてのPARTNERデバッガコマンドがサポートされているわけではありません

    • 呼び出し履歴

      PCの現在位置(FMP/FMP3 の場合は選択中のコアのPC現在位置)について呼び出し履歴を表示

    • コードカバレッジ

      コードカバレッジ のウインドウを表示

    • コア

      コア選択ウインドウを表示

    • 関数トレース

      関数トレース ウインドウを表示

    • トレース (※未対応) 近日対応予定

    • スレッド

      有効な全タスクおよび割り込みコンテキストの呼び出し履歴等の情報を一覧表形式で表示

    • モジュール

      シンボル情報を読み込んだ ELF ファイルの一覧表示

    • プロセス (※未対応)

    • RTOSビューアー

      RTOSビューアー のウインドウを表示

    • イベントトラッカー

      イベントトラッカー のウインドウを表示

    • メモリ

      メモリダンプウインドウを表示。表示後アドレスを指定

    • 逆アセンブル

      ソースウインドウで選択されているソースを逆アセンブル表示

    • レジスタ

      レジスタ表示ウインドウを表示します。 デフォルトは汎用レジスタのみですが、FPUのレジスタ内容も表示可能です


  • デバッグ開始

    デバッグの実行開始

  • デバッグなしで開始 (※未対応)

  • 続行

    ブレークしているデバッグの実行再開

  • すべて中断

    実行の強制ブレーク

  • デバッグの停止

    デバッグ実行の終了 (SOLIDでは"すべて中止"と同じ)

  • すべてデタッチ (※未対応)

  • すべて中止

    デバッグ実行の終了 (SOLIDでは"デバッグの停止"と同じ)

  • 再起動

    デバッグ実行を最初からやり直し

  • プロセスにアタッチ (※未対応)

  • 例外 (※未対応)


  • ステップイン

  • ステップオーバー

  • ステップアウト


  • クイックウォッチ

    式を入力して値を評価します


  • ブレークポイントの設定/解除

  • ブレークポイントの作成
    • 関数でブレーク

    • 新しいデータブレークポイント

  • すべてのブレークポイントの削除

  • すべてのブレークポイント有効にする

  • すべてのブレークポイントを無効にする


  • すべてのデータヒントをクリア

  • データヒントのエクスポート

  • データヒントのインポート

    データヒントの操作。デバッグ中のマウスホバーで表示されているツールチップをピン止めしている場合、使用可能です


  • 名前を付けてダンプを保存 (※未対応)


  • オプションと設定

    SOLID-IDE のデバッグオプション設定

  • <プロジェクト名>のプロパティ

    スタートアッププロジェクトのプロパティ設定


ツールメニュー

  • プロセスにアタッチ (※未対応)


  • コードスニペットマネージャ (※未対応)


  • ツールボックスアイテムの選択 (※未対応)


  • アドインマネージャ (※未対応)

  • 拡張機能と更新プログラム

    拡張機能のアドオンを管理


  • 外部ツール

    外部ツールを登録してメニューから実行できるように設定


  • 設定のインポートとエクスポート (※未対応)

  • カスタマイズ

    ツールバーやメニューのカスタマイズ

  • オプション

    SOLID-IDE (Visual Studio) 動作オプションの設定


KMC(SOLID_V7A_ARM)

  • PARTNER Package について

    PARTNER Package のバージョン番号表示


KMC(SOLID_V8A_AARCH64)

  • PARTNER Package について

    PARTNER Package のバージョン番号表示


ウインドウメニュー

ウインドウの構成を設定

  • 新規ウインドウ

  • 分割


  • フローティング

  • すべてフロート表示

  • ドッキング

  • ドッキングタブ付きドキュメントとしてドッキング

  • 自動的に隠す

  • 非表示


  • タブを固定する


  • すべて自動に隠す

  • 水平タブグループの新規作成

  • 垂直タブグループの新規作成

  • すべてのドキュメントを閉じる

  • ウインドウレイアウトのリセット


ヘルプメニュー

  • ライセンスツール
    • Jet2ラインセンスツール

      ノードロックライセンスの設定・確認ツール

    • PCライセンスツール

      フローティングライセンスの設定・確認ツール


  • About SOLID-IDE

    SOLID全体のバージョンおよび、組み込まれているSOLIDコンポーネントのバージョンの表示