ビルドエラーメッセージの出力方法制御

ビルド実行中は、出力ウインドウにビルドの進行状況や コンパイラが出力したエラー/警告が出力されます。

最終的にエラー/警告だけを F4 で追いたい場合に、2種類の手順があります。

エラー一覧ウインドウを表示させる

ビルド後に、メニューの 表示(V) ‣ エラー一覧(I) を選択します。または、Ctrl+¥ , E で開きます。

../../_images/menu-view-error-list.png

エラー一覧の例

../../_images/error-list-window.png

次の設定をすることで、ビルド後に自動的にエラー一覧を表示させることができるようになります。

  1. メインメニューの ツール(T) ‣ オプション(O).. を選択します。

  2. プロジェクトおよびソリューション ‣ 全般 を選択します。

  3. ビルド完了時にエラー一覧を表示 にチェックを入れます。

../../_images/option-window-error-list-on.png

ビルド時の出力メッセージを簡易に設定する

ビルド時の出力ウインドウに表示される内容は何段階かのレベルに設定できます。 その中の「簡易」レベルに設定することで、ビルドの開始メッセージと、 エラー/警告メッセージのみが出力されるようになります。

簡易表示の一例

../../_images/simple-output-message-window.png

簡易に設定する手順

  1. メインメニューの ツール(T) ‣ オプション(O).. を選択します。

  2. プロジェクトおよびソリューション ‣ ビルド/実行 を選択します。

  3. MSBuildプロジェクトビルド出力の詳細簡易 に変更します。

../../_images/option-window-simple-error.png